Hummer EV not charging

Lutch01

New member
Sep 23, 2023
10
11
Plugged in my HEV to charge using the optional level 2 charger overnight. Received a text message around 8am that stated charging has stopped. Noticed that it was not dully charged and charging stopped prematurely. Drove the truck later that day and the check engine light came on. Since then, the truck is not charging using any method or type of charger, private or public. Took it to GMC today and the pulled a few codes. Taking it back on Monday as I didn’t want to leave the truck over the weekend at the dealership.

Two days before, drove though a heavy downpour. Will share progress.

If anyone else had this issue, kindly share the details.

TY.
 
This is the first I have heard of this. I hope it's a simple fix. Please keep us posted!
 
Update:
Did a hard reset myself by disconnecting the ground on the 12v battery. Left it off for 30mins. Started the vehicle, followed the on screen prompts to turn windows down then up. Drove it for 10 mins, no CEL light after hard reset. Got back home and plugged in level 2, now charging properly.
Note: GMC pulled about 8 codes yesterday. They said the vehicle would have been there indefinitely. I requested that they perform. A hard reset. They said that their HEV tech would have to contact TAC even to do that. Glad to know that we can simply do a hard reset to correct issues. Unless there’s a physical hardware/software issue, then dealership is required.
 
Update:
Did a hard reset myself by disconnecting the ground on the 12v battery. Left it off for 30mins. Started the vehicle, followed the on screen prompts to turn windows down then up. Drove it for 10 mins, no CEL light after hard reset. Got back home and plugged in level 2, now charging properly.
Note: GMC pulled about 8 codes yesterday. They said the vehicle would have been there indefinitely. I requested that they perform. A hard reset. They said that their HEV tech would have to contact TAC even to do that. Glad to know that we can simply do a hard reset to correct issues. Unless there’s a physical hardware/software issue, then dealership is required.
Let's hope that did the trick and it was just a fluke! 🤞
 
Hopefully akin to when a hard reset is required on a computer or phone. Note that the dealership didn’t recommend this. There is a story of another owner who experienced the same issue. The dealer kept his car for a week, couldn’t find any problem. Gave the vehicle back to the owner. The owner then discovered the hard reset recommendation online, performed it and all was well.
 
I think they are going to have to come up with an easier way to do a hard reset because I've heard of people having to do them often :(
 
Not difficult. Took me less than 10 minutes. They made the cover extremely well and very easy to remove and replace.
 
Update. Those who have the Ultium chargers that get the sporadic amber light and no charging. The fix is to completely seat the removable plug into the charger. I had to press down onto an edge to get it seated properly. Never had an issue again…
 
Update. Those who have the Ultium chargers that get the sporadic amber light and no charging. The fix is to completely seat the removable plug into the charger. I had to press down onto an edge to get it seated properly. Never had an issue again…

Maybe we need to create a thread dedicated just to that with pictures to help people who have the issue?
 
Update. Those who have the Ultium chargers that get the sporadic amber light and no charging. The fix is to completely seat the removable plug into the charger. I had to press down onto an edge to get it seated properly. Never had an issue again…
Good to know, thank you!
 
Back
Top